最近在由于某个开发的移动平台的工作环境变成了 Firefox,在一次重新安装了 Ubuntu 系统之后,mp3 无法正常播放,提示错误大致如下

 Warning: Cannot play media. No decoders for requested formats: audio/mpeg

不管是通过是 <audio src></audio> 还是 new Audio() 的方式,都报出这个错误,最后总结出来三条解决方法:

  1. 安装 ubuntu-restricted-extras sudo apt-get install ubuntu-restricted-extras
  2. 安装 gnash sudo apt-get install gnash (一个 gnu 做的 flash 播放器,其中包含了浏览器插件)
    这条比较容易忽略,虽然我也不明白为什么 Firefox 调用解码器还和 flash 有关。
  3. 安装最新版的 Firefox,实测 59 版本就算满足了上面两条,还是无法正常播放,而 63 版本正常。

标签: ubuntu, firefox, mp3, audio, flash

添加新评论